Bienvenue à Blogs CodeS-SourceS Identification | Inscription | Aide

Le blog de Patrick [MVP Office 365]

Partage d'informations sur Office 365, SharePoint, Yammer et au-delà...

Actualités








  • Versions :
    14.0.4730.1010 SharePoint 2010 RC
    14.0.4762.1000 SharePoint 2010 RTM
    14.0.6029.1000 SharePoint 2010 SP1

    15.0.4128.1014 SharePoint 2013 Preview
    15.0.4420.1017 SharePoint 2013 RTM
    15.0.4569.1509 SharePoint 2013 SP1

    Les derniers CU pour SharePoint 2010...
    Les N° de version pour SharePoint 2013...



Retours d’expérience Installations SharePoint Foundation…

Ayant eu l’occasion de superviser plusieurs installations SharePoint Foundation 2010 ces derniers temps, j’ai pu constater que la documentation disponible sur le Net était largement moins fournie que pour SharePoint Server, c’est pourquoi je voudrais en profiter pour vous faire part de quelques problèmes fréquemment rencontrés.

Problème n°1 : L’installation de SQL Server (Express ou STD ou Enterprise) se bloque sur le compte de service. Le message d’erreur ressemble à cela : image

Cela se produit même lorsque le mot de passe saisi est correct et lorsque l’on exécute l’installeur sur un compte ayant les privilèges “Administrateur local” mais qui n’est pas le compte de domaine. En effet, dans ce cas le compte local bien qu’il soit de niveau “Administrateur”, n’a pas accès aux ressources du domaine et ne peut pas valider le compte de domaine.

Tout rentre dans l’ordre si l’on se délogue et on se relogue en utilisant le compte de domaine cible (ici Admin SQL du domaine SP) :

image

Morale : il faut se connecter avec un compte de domaine si l’on veut affecter un compte de domaine à SQL Server.

Problème n°2 : Ce problème se manifeste de différentes façon après l’installation principale de SharePoint Foundation. Les symptômes que j’ai relevés sont :

- absence du menu “Configurer la collection des données d’utilisation et d’intégrité” (comme sur la copie d’écran ci-dessous) :

image

- impossibilité d’accéder à l'écran de configuration des services (Administration Centrale / Paramètres système / Gérer les serveurs de cette batterie / <nom du serveur>

- impossibilité de gérer les paramètres de sécurité d’IE9

Ces symptômes disparaissent dès que l’on désactive l’UAC  :

image

Ainsi l’administration Centrale redevient :

image

Problème n°3: sur le serveur “intranet.masociete.com”, l’accès au site http://intranet.masociete.com est impossible mais http://intranet et http://intranet.masociete.local sont OK

Eh bien, il faut savoir que ce comportement (qui peut être déroutant) est tout à fait normal !!!

Le problème vient du fait que le comportement d’IE sur ce cas de figure est le même que lorsque l’on tape le mot de passe d’accès au compte avec une erreur : il représente la fenêtre de login au site.

En utilisant un autre navigateur, on constate que l’erreur remontée est une erreur 401 :

HTTP 401.1 - Non autorisé : Échec de l'ouverture de session

De plus, le problème ne se produit que si vous essayez de parcourir le site Web directement sur le serveur. Si vous accédez au site Web à partir d'un ordinateur client, le site Web fonctionne comme prévu.

Il s’agit en fait à l’origine d’un blocage de sécurité pour éviter certains exploits utilisant un compte local pour attaquer un site situé sr le même serveur.

Mais cela peut avoir des effets plus ou moins pervers sur une configuration SharePoint :

- pas d’indexation si l’indexeur est situé sur le serveur frontal

- pas de connexion si une tâche tente de se connecter sur un site

- pas de connexion possible pour un code dédié se connectant depuis le serveur

 

Reste donc 4 possibilités d’actions :

- Configurer la clé de registre “DisableLoopBackCheck” dans la ruche

“HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa”. Cependant cela est FORTEMENT DECONSEILLE sur une machine de production !

- Configurer une liste d’adresses qui doivent être exclues de la vérification

- Créer des URLS d’accès distincts (dans mon exemple http://intranet fonctionne alors que http://intranet.masociete.com est bloqué)

- Modifier l’architecture

Pour plus de détails sur ce problème, je vous recommande les deux liens suivants :

SNAGHTMLe8c324

En espérant que ces quelques éléments vous permettrons de gagner un peu de temps ! Clignement d'œil

Ce post vous a plu ? Ajoutez le dans vos favoris pour ne pas perdre de temps à le retrouver le jour où vous en aurez besoin :
Posted: lundi 19 septembre 2011 12:30 par Patrick Guimonet

Commentaires

Pas de commentaires

Les commentaires anonymes sont désactivés

Les 10 derniers blogs postés

- « Naviguer vers le haut » dans une librairie SharePoint par Blog de Jérémy Jeanson le 10-07-2014, 13:21

- PowerShell: Comment mixer NAGIOS et PowerShell pour le monitoring applicatif par Blog Technique de Romelard Fabrice le 10-07-2014, 11:43

- ReBUILD 2014 : les présentations par Le blog de Patrick [MVP Office 365] le 10-06-2014, 09:15

- II6 Management Compatibility présente dans Windows Server Technical Preview avec IIS8 par Blog de Jérémy Jeanson le 10-05-2014, 17:37

- Soft Restart sur Windows Server Technical Preview par Blog de Jérémy Jeanson le 10-03-2014, 19:43

- Non, le certificat public du CA n’est pas un certificat client !!! par Blog de Jérémy Jeanson le 10-03-2014, 00:08

- Windows Server Technical Preview disponible via MSDN par Blog de Jérémy Jeanson le 10-02-2014, 19:05

- Focus Sauvegardes SharePoint par Le blog de Patrick [MVP Office 365] le 10-02-2014, 13:11

- Technofolies, votre évènement numérique de l'année par Le Blog (Vert) d'Arnaud JUND le 09-26-2014, 18:40

- Xamarin : From Zero to Hero par Fathi Bellahcene le 09-24-2014, 17:35