Bienvenue à Blogs CodeS-SourceS Identification | Inscription | Aide

Le blog de Patrick [MVP SharePoint]

Partage d'informations sur SharePoint et d'autres technologies Microsoft (et à l'occasion non Microsoft)...

Actualités








  • Versions :
    14.0.4730.1010 SharePoint 2010 RC
    14.0.4762.1000 SharePoint 2010 RTM
    14.0.6029.1000 SharePoint 2010 SP1

    15.0.4128.1014 SharePoint 2013 Preview
    15.0.4420.1017 SharePoint 2013 RTM
    15.0.4569.1509 SharePoint 2013 SP1

    Les derniers CU pour SharePoint 2010...
    Les N° de version pour SharePoint 2013...



Pb lors de l’installation SharePoint 2010…

Lors de l’installation de SharePoint 2010, j’ai rencontré un problème de plantage à l’étape 5 du configuration Wizard.

Ca se termine sur cet écran :

capture_12032010_113045

Et en analysant le fichier de journalisation, on remarque vers la fin des 15000 et quelques lignes !, le message suivant :

An exception of type System.ServiceProcess.TimeoutException was thrown.  Additional exception information: Time out has expired and the operation has not been completed.
System.ServiceProcess.TimeoutException: Time out has expired and the operation has not been completed.
   at System.ServiceProcess.ServiceController.WaitForStatus(ServiceControllerStatus desiredStatus, TimeSpan timeout)
   at Microsoft.SharePoint.Win32.SPAdvApi32.StartService(String strServiceName)
   at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.Start()
   at Microsoft.SharePoint.Administration.SPWindowsServiceInstance.Provision(Boolean start)
   at Microsoft.SharePoint.Search.Administration.SPSearchServiceInstance.Provision()
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstanceInConfigDB(Boolean provisionTheServiceInstanceToo, String serviceInstanceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServiceInstances(Boolean provisionTheServiceInstancesToo, String serviceRegistryKeyName, Object sharepointServiceObject)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.InstallServices(Boolean provisionTheServicesToo)
   at Microsoft.SharePoint.PostSetupConfiguration.ServicesTask.Run()
   at Microsoft.SharePoint.PostSetupConfiguration.TaskThread.ExecuteTask()

En résumé et après analyse le service de Search ne démarre pas.

Le thread suivant :

SharePoint 2010 Fails Installing On Step 5 Of The Configuration Wizard

http://social.msdn.microsoft.com/Forums/en/sharepoint2010general/thread/ec0239c1-4451-46dc-ac3a-baffa006c024

aide à résoudre le problème en proposant 2 solutions :

- supprimer des clés de registre (ca peut régler le problème mais c’est surement une très mauvaise idée à déconseiller fortement)

- changer à la volée (pendant que le Wizard est en attente sur l’étape 5) les paramètres de connexion des deux services de recherche :

En anglais En français
  • SharePoint Foundation Search V4
  • SharePoint Server Search 14
 

Pour cela lancer services.msc, retrouver le premier service et faire propriétés :

image

Changer en Compte système local :

image

et démarrer le service : image

Le Wizard doit alors avancer d’une étape et bloquer à nouveau sur le service de recherche suivant :

image

Faire de même pour le 2e service de recherche et alors le wizard peut aller jusqu’au bout !

image

Ce post vous a plu ? Ajoutez le dans vos favoris pour ne pas perdre de temps à le retrouver le jour où vous en aurez besoin :
Posted: vendredi 12 mars 2010 14:08 par Patrick Guimonet
Classé sous :

Commentaires

ROMELARD Fabrice a dit :

Ba pour être franc, ce n'est vraiment pas la seule erreur que j'ai eu lors de l'installation de SP2010.

Que ce soit la Beta2 ou la RC

J'espère que ce sera réellement amélioré avec la version RTM

# mars 14, 2010 16:35

Patrick Guimonet a dit :

Pour ma part ce fut la seule erreur vraiment bloquante mais ca me rassure : je croyais que les problèmes venaient de moi ! :-)

Vivement la RTM !

# mars 26, 2010 09:38
Les commentaires anonymes sont désactivés

Les 10 derniers blogs postés

- [ #Yammer ] From Mailbox to Yammer and back / De votre messagerie vers Yammer et retour ! par Le blog de Patrick [MVP SharePoint] le 09-15-2014, 11:31

- [ #Office 365 ] New service settings panel / Nouveau panneau de paramétrage des services par Le blog de Patrick [MVP SharePoint] le 09-11-2014, 08:50

- Problème de déploiement pour une démo SharePoint/TFS? par Blog de Jérémy Jeanson le 09-10-2014, 21:52

- [ #Office365 ] Delve first impressions / Premières impressions sur Delve par Le blog de Patrick [MVP SharePoint] le 09-09-2014, 16:57

- [ #Office365 ] How to change Administration console language ? / Comment changer la langue de la console d’administration ? par Le blog de Patrick [MVP SharePoint] le 09-09-2014, 08:25

- [ #SharePoint 2013 ] Suppression de bases de données en état “Pas de Réponse” par Le blog de Patrick [MVP SharePoint] le 09-04-2014, 14:10

- Changer l’adresse d’une ferme Office Web Apps associée à SharePoint par Blog de Jérémy Jeanson le 09-01-2014, 22:21

- Une ferme #SharePoint 2013 dans @Azure en quelques clics (1ère partie) ! par Le blog de Patrick [MVP SharePoint] le 08-28-2014, 18:52

- SharePoint 2013: Préparation de la migration - Création des site Templates dans 2010 et 2013 par Blog Technique de Romelard Fabrice le 08-20-2014, 16:31

- [ #Yammer ] How to change interface language ? Comment changer la langue de l’interface ? par Le blog de Patrick [MVP SharePoint] le 08-20-2014, 14:21